RASPLOT Tutorial

Learning Objectives
-Understand the purpose of RASPLOT and its use in the National Flood Insurance Program (NFIP)
-Understand the structure of RASPLOT and be comfortable with the RASPLOT menu options
-Learn how to use RASPLOT to create flood profiles from U.S. Army Corps of Engineers (USACE) Hydrologic Engineering CenterRiver Analysis System (HEC-RAS) and HEC-2 hydraulic models
-Understand the capabilities of RASPLOT

INTRODUCTION
Hi, I am Renee, your guide through the RASPLOT Tutorial.
Let's begin by giving you an Introduction to this tutorial. Click the "Overview" button located in the main menu on the left to start the
tutorial.

Overview - Introduction
This tutorial will discuss the basic concepts of the RASPLOT program and demonstrate its use. The tutorial consists of three sections
- "Overview," "Setup and Navigation," and "Examples."
· RASPLOT is a program that was developed by the Federal Emergency Management
Agency to allow users to create flood profiles from HEC-2, HEC-RAS, as well as
input and output from other hydralic models.
Prior to running the RASPLOT program for the first time, the user should:
- Be familiar with the National Flood Insurance Program
- Be familiar with the HEC-2 and HEC-RAS hydraulic modeling programs
- Have a basic understanding of Microsoft Windows
- Have the HEC-2 and HEC-RAS programs installed on his/her system.

RASPLOT and the National Flood Insurance Program (NFIP)
Communities participating in the NFIP receive a Flood Insurance Study (FIS), which includes a flood profile for each detailed
flooding source in the community. Flood profiles graphically present elevations computed by step-backwater computer programs.
The programs most often used in the hydraulic analyses, reflected in FISs, are HEC-2 and
HEC-RAS, both of which were developed by the USACE Hydrologic Engineering Center.

RASPLOT and the National Flood Insurance Program (continued)
Traditionally, Flood Insurance Study (FIS) flood profiles were manually drafted by cartographers and photo-reproduced for inclusion
in final FISs. To reduce the time and effort involved in converting HEC-2 data to flood profiles suitable for publishing in FISs, the
Federal Emergency Management Agency developed FISPLOT, an automated FIS flood profile generating program. As the use of
HEC-RAS became more prominent, the need arose for the development of a program to generate flood profiles from HEC-RAS.
FEMA developed the RASPLOT program to fill this need.

RASPLOT and the National Flood Insurance Program
(continued)
RASPLOT is a computer program that creates a Flood Insurance Study (FIS) flood profile
by automatically extracting data from HEC-2 or HEC-RAS input and output files. In addition, the RASPLOT program can be used to
create FIS flood profiles for any other hydraulic model by manually entering the necessary data. The final product is in Drawing
Interchange
Format (DXF). A Computer-Aided Design and Drafting (CADD) program is included
as part of this program to edit and print profiles.

RASPLOT and the National Flood Insurance Program (continued)
RASPLOT-generated flood profile drawings contain all Federal Emergency Management Agency-specified profile lines, grid lines,
cross section symbols and letters, elevations, and labels for selected hydraulic structures. RASPLOT automatically corrects any
elevation drawdowns that may result from its interpretation of data from the HEC-2 or HEC-RAS modeling. In addition, RASPLOT
maintains a database of all profiles plotted to accommodate revisions and re-plotting.

The Profile Table Database
The Profile Table Database is a Microsoft® Access® database that is automatically created when data are extracted from HEC-2 or
HEC-RAS models. The database may also be manually created for use with other hydraulic models. The Profile Table
Database is used to store all pertinent model information for use in the RASPLOT program. The Profile Table Database includes four
tables.
More detailed information concerning the Profile Table Database is provided as part of the examples found later in this tutorial.
NOTE: The user should not modify the Landmark, Panel, or Work Header tables outside of RASPLOT. In addition, the data inside
the Working table should not be sorted. Sorting this table may cause RASPLOT to malfunction.

The Profile Table Database (continued)
Creating a Profile Table Database for HEC-2
· Select the HEC-2 option from the "Select a Model" section of the "Open File"
window.
· After the HEC-2 input file is open, select the "Extract Data" button to run the
HEC-2 program and create the corresponding Profile Table Database.
Creation of a Profile Table Database for HEC-2 is demonstrated in the HEC-2 Example found later in this tutorial.

The Profile Table Database (continued)
Creating a Profile Table Database for HEC-RAS
· When opening a new file in RASPLOT, the HEC-RAS option is selected in
the "Select a Model" section of the "Open File" window by default.
· The RASPLOT program extracts data from the HEC-RAS report file, for the
selected project file, and automatically creates a Profile Table
Database for the file.
· If the HEC-RAS report file is missing, RASPLOT will prompt the user to open
HEC-RAS in order to create the Report File. RASPLOT will then
automatically create a special user-defined table named "RASPLOT." This
table is used to create the report file for use in RASPLOT.
Creation of a Profile Table Database and the RASPLOT report
file for HEC-RAS is demonstrated in the HEC-RAS example
found later in this tutorial.

The Profile Table Database (continued)
Creating a Profile Table Database for Other Hydraulic Models
· Choose the "Create Blank Database" option from the "File" menu to open a
folder on the local system or on a network drive.
· Enter the number of profiles to be plotted in the pop-up window.
· Open the table using Microsoft® Access® and insert the necessary data into
the Working table.
· Open the Access® .mdb file in RASPLOT to complete plotting of the profile.
Note: The user should not modify the Landmark, Panel, or Work Header tables outside of RASPLOT. In addition, the data inside the
Working table should not be sorted. Sorting this table may cause RASPLOT to malfunction.

Drawing Interchange Format (DXF) Editor
The DXF editor allows the user to view, modify, and print DXF files. This editor is a fully functional Computer-Aided Design and
Drafting (CADD) program that allows the user to create, erase, trim, explode, rotate, scale, copy, move, and format objects. In
addition, the DXF editor allows the user to save any changes in either DXF or Drawing File Formats that are AutoCAD® Versions
13/14/2000 compliant. RASPLOT will save the drawings that it creates as DXF files, by default.
The DXF editor opens any DXF file created inside or outside of the RASPLOT program.
More detailed information concerning the
DXF Editor is provided as part of the examples
found later in this tutorial.

Overview Summary
Congratulations on completing the RASPLOT Tutorial Overview section. Here is a summary of what we have learned thus far:
· RASPLOT is a program that was developed by the Federal Emergency Management
Agency to allow users to create flood profiles from HEC-2, HEC-RAS, as well as
input and output from other hydralic models.
· A Microsoft® Access® database is used to store all pertinent model
information for use in the RASPLOT program.
· The RASPLOT program includes a Drawing Interchange Format (DXF) editor
that allows the user to view, modify, and print DXF files. The editor allows
the user to save changes in either DXF or Drawing File Formats that are
AutoCAD Versions 13/14/2000 compliant.
Click on "Setup and Navigation" located at left in the main menu to move on to next section of the tutorial.

Setup and Navigation - RASPLOT Program Window
The RASPLOT Program Window contains the RASPLOT Menu, Tool, and Status bars.

RASPLOT Menu Bar
The RASPLOT Menu bar includes the File, View, Edit, and Help menus.
To get details concerning the various components of RASPLOT menu, click on the "Show Me" button.

RASPLOT Tool Bar
The RASPLOT toolbar is comprised of several buttons that execute program functions.

RASPLOT Status Bar
The Status Bar displays the current program. It also displays the cumulative distance (X) and corresponding elevation (Y) of the
mouse pointer location.

RASPLOT Setup
After you download RASPLOT to your local system, you will need to configure the program so that it can find the HEC-2 and HEC
RAS program files on your system. RASPLOT can run only if the HEC-2 and HEC-RAS programs are installed on the same
computer.

Additional RASPLOT Functions
River/Reach Connection
· This dialog box allows for HEC-RAS models with multiple stream reaches or
different streams/reaches to be plotted separately.

Additional RASPLOT Functions (continued)
Backwater Setup
· This window allows the user to enter backwater elevations for the
corresponding flood profiles. RASPLOT will automatically plot the
backwater elevation up to the point that the riverine profile controls.

Additional RASPLOT Functions (continued)
Select Profile
· This window allows the user to select the flood profiles to plot.

Additional RASPLOT Functions (continued)
Header Information
· This window allows the user to edit the Community Name, County Name,
State Name, Stream Name, and Stream Distance for a given flood profile.
· When the Drawing Interchange Format file is created, RASPLOT will add
the words "Stream Distance in," the selected unit, and the specified descriptor
(e.g., "Stream Distance in Feet Above Corporate Limits") to the flood profile.

Additional RASPLOT Functions (continued)
Panel Setup Information - General Tab
· The user may view and edit the Community Name, County Name, State,
Stream Name, Stream Distance, Starting Station, End Station, Starting
Elevation, and Ending Elevation of each flood profile panel. To reduce the
length of the first panel, retype the end station. The same station should be
entered as the starting station for the next panel.

Additional RASPLOT Functions (continued)
Panel Setup Information - General Tab (continued)
· The user is given the option of plotting the flood profile in different units.
"Feet," "Hundred Feet," "Thousand Feet," "Mile," "Meters," and "Kilometers"
are available for use.
· The user may view and edit the horizontal and vertical scale of each
panel. The horizontal scale options of 100, 200, 400, 500, 1000, and 2000
feet and vertical scales of 5, 10, and 20 feet are provided in the pull-down
menus. Use the pull-down menus to select the desired scale options.
Note: To calculate the horizontal scale for the units of miles, use the formula, Horizontal Scale = Desired Interval * 5280 [i.e., 528 =
0.1 * 5280]. Enter horizontal scales of 528, 1056, and 2640 feet to get exact horizontal labels of 0.1, 0.2, and 0.5-miles, respectively.
When selecting meters or kilometers, RASPLOT assumes that the input from HEC-2 and HEC-RAS is in meters.

Additional RASPLOT Functions (continued)
Panel Setup Information - Detail Tab
· For individual panels, only vertical scales may be changed.
· Manipulation of the X and Y origins allow the user to adjust panels vertically or
horizontally. For example, for a panel with a vertical scale of 5, reducing the
number in the Y Origin column by 10 will move the panel up 2 inches.

Additional RASPLOT Functions (continued)
Landmark Table
· The "Landmark Table" window allows the user to insert horizontal or vertical
notes at any point along the profile. This function is not limited to cross section
locations. RASPLOT will automatically compute the cumulative distance and
elevation at any point selected.
· The Landmark Table includes columns for:
- Cumulative Distance: The horizontal starting point for text location along the flood profile.
- Elevation: The vertical starting point for text location along the flood profile.
- Text: The exact text that will be printed on the profile.
- Orientation: Determines whether the text will be printed vertically or horizontally.
- Adjusted: Determines text justification.
- Underline: Determines whether or not the text will be underlined.

Setup and Navigation Summary
Congratulations, you have completed the Setup and Navigation section of this tutorial. Here is a review of the key points discussed in
this section.
· RASPLOT includes File, View, Edit, and Help menus that allow the user to
manipulate files and get more information about the RASPLOT program.
· Several RASPLOT functions may also be accessed with a single mouse-click
from the RASPLOT Toolbar.
· The RASPLOT Status Bar provides information concerning the active program
function or the current file. It also displays the cumulative distance and
corresponding X and Y coordinates for the location of the mouse pointer.
· If you are using Rasplot for the first time, you will need to configure the program so that it
can find the HEC-2 and HEC-RAS program files on your system.
· RASPLOT includes additional functions that allow the user
to manipulate and control the format of final flood profiles.
Click on "Examples" located at left in the main menu
to move on to next section of the tutorial.

Examples Section
This section provides examples to help you understand how to run RASPLOT to create a flood profile from either a HEC-2 or HEC
RAS model. The problems will demonstrate how to enter lettered cross section and road name labels, specify scale, and enter
community information to affect the overall layout of flood profiles.
Select the example you would like to view, or select the "Generate Certificate" button to generate a certificate of completion and quit
the tutorial.

HEC-2 Example - Opening a HEC-2 Input File in RASPLOT
· Launch the RASPLOT program and select the "Open" button.
· Open a HEC-2 input file. Select HEC-2 in the "select a model" box.
· Select the HEC-2 file from the known directory and drive on your local system,
then click the "OK" button.

Opening a HEC-2 Input File in RASPLOT (continued)
· Notice that RASPLOT runs the HEC-2 program automatically. Close the
DOS screen when it says "Normal Program Termination."
Note: Depending on the configuration of your computer, the DOS window may automatically close

Extracting HEC-2 Data
· Click on the "Extract" button to extract the model information.

Viewing and Editing the Profile Table Database
Scroll across this interface and notice the yellow cells. Information found in these cells can be edited.

Viewing and Editing the Profile Table Database (continued)
· Click on the "Data" button and enter lettered cross sections at the following
river stations: River Station 5135 - Section A; 7720 - B; 9940 - C; 12040 D; and 12790 - E. Note: This places lettered cross sections on the flood profile
· Enter "Mt. Weather Road" at River Station 9890 in the "Label Text" field.

Viewing and Editing the Profile Table Database (continued)
· The first surveyed cross section, River Station 4130, is actually 500 feet
downstream of the corporate limits. RASPLOT assumes that the first cross
section is at a cumulative distance of zero. This can be corrected by selecting
"Recompute Cumulative Distance" from the "Edit" menu.
· Enter -500 feet as the starting cumulative distance in the "Input" window.
Note: The value is negative because the station is downstream of the corporate limits.

Viewing and Editing the Profile Table Database (continued)
Click on "OK" and notice that the cumulative distance ("Cum Dist") column
of the Profile Table Database decreases by 500 feet at each cross section.

Viewing and Editing the Profile
· Click on the "Plot" Button.
· Depending on the particular file, the way RASPLOT displays the flood profile
may or may not be appropriate. If elements of the flood profile do not display
within the 11" x 17" page border, you will have to adjust the flood profile
layout to accommodate this information.

Viewing and Editing the Profile (continued)
· To label the corporate limits on the flood profile, select "Edit Landmark
Table" from the "Edit" menu and enter the necessary information. Click
"OK" to save the changes. Note: This table allows you to enter "landmarks" on the flood profile.

Viewing and Editing the Profile (continued)
Notice the gray lines that now appear on the left and right side of the panel. These lines indicate the location of the corporate limit
labels on the flood profile.

Viewing and Editing the Profile (continued)
· Click on the "Panel" button and enter the necessary data under the
"General" tab.
Note: Information entered in the "Panel Setup Information" window is displayed in the title block of the flood profile.

Viewing and Editing the Profile (continued)
· Next, enter the necessary data under the "Detail" tab.
Note: Only the "Start Station," "End Station," "Origin X," and "Origin Y" fields may be edited by the user.

Saving the Profile Table Database
· Click on the "Save" button to save the file. Save the file as "HEC-2.mdb".
The .mdb file that is saved here is the source file for the data used to generate the flood profile. It is important that you save this file
so that you have the flexibility to modify your data and generate updated profiles in the DXF editor.

Creating and Viewing the DXF File
· Click on the "DXF" button to create a DXF file. Name the file "HEC2.dxf." Click "Save."
· Select "DXF Editor" from the "File" menu. This will launch the DXF Editor
and open the profile created for this HEC-2 file.

Creating and Viewing the DXF File (continued)
· Notice that the Corporate Limits label is not positioned correctly.
· Click on the "Zoom Window" button on the top toolbar and zoom in on the
label.
· Click on the "Move" button on the left toolbar and move the label to the right
approximately one block.
· Click on the "Save" button to save the revised flood profile.
Note: This file can be opened in AutoCAD® as a Drawing Interchange Format or Drawing Format File (DWG). Save the file as a
DWG file for use in
AutoCAD®.

End of HEC-2 Example
Congratulations, you have completed the HEC-2 Example! You are now ready to print the final flood profile.
Print Dialog:
-Select "Print" from the "File" menu.
-Select "Click Pick" and then select the corners of the flood profile.
-Select the "Snap to Endpoint" icon located at the top of the right toolbar.
-Select "Printer" from the "Print Dialog" menu.
-In the "Print Setup" window, select the size of the profile (choose 11" x 17" and
"Landscape" under the "Orientation" setting).
-Choose "0" for Origin's "X" and "Y", to center the profile plot.
-Select "Print" from the "Print Dialog" menu.

HEC-RAS Example - Opening a HEC-RAS Project File in RASPLOT
· Launch the RASPLOT program and select "Open" button.
· Open a HEC-RAS project file. Select HEC-RAS in the select a model box. Select the
the HEC-RAS file from the known directory and drive on your local system, then click
the "OK" button.

Extracting HEC-RAS Data
· Click on the "Extract" button to extract the model information.
· If RASPLOT has not been run on this file before, it will be missing the
HEC-RAS Report file (HECRAS.rep). RASPLOT will prompt you to create
this file. Click "Yes" in the RASPLOT dialog box.
Note: This only occurs if the HEC-RAS report file does not already exist.

Extracting HEC-RAS Data (continued)
· RASPLOT will automatically open the file in HEC-RAS.

Extracting HEC-RAS Data (continued)
· Select "Generate Report" from the "File" menu.
· Because HEC-RAS was opened by RASPLOT, the correct options should
already be selected in the "Report Generator" window. Ensure that the
following check-boxes are selected: Plan Data, Geometric Data, and Reach
Lengths.
· All four profiles should be included in the report (Output section).
RASPLOT should be the only table included in the "Selected Summary Table" section of this window.
Note: No check-boxes should be selected under the "Specific Tables" section of this window. The "Summary of Errors, Warnings,
and Notes" check-box should also not be selected. An incorrect report will result if any of these options are selected.

Extracting HEC-RAS Data (continued)
· Click on the "Generate Report" button.
· After the report is generated, click on the "Close" button.
· In the HEC-RAS main menu, select "Exit" from the "File" menu.

Extracting HEC-RAS Data (continued)
· In RASPLOT, click on the "Extract" button again.
Note: Because the report file has been created, RASPLOT
will now complete the extraction.

Viewing and Editing the Profile Table Database
· Scroll across this interface and notice the yellow cells. Information found in
these cells can be edited.

Viewing and Editing the Profile Table Database (continued)
· Click on the "Data" button and enter lettered cross sections at the following
river stations: River Station 930 - Section A; 1550 - B; 1700 - C; 2350 - D;
and 2475 - E. Note: This places lettered cross sections on the profile which correspond to those on the FIRM
· Enter the following road names at the appropriate river stations: Station
1587.5 - "FEMA Avenue," Station 2387.5 - "NFIP Street."

Viewing and Editing the Profile
· Click on the "Plot" button.
· Depending on the particular file, the way RASPLOT displays the the flood profile may
or may not be appropriate. If elements of the flood profile do not display within the
11" x 17" page border, you will have to adjust the flood profile layout to
accommodate this information.

Viewing and Editing the Profile (continued)
· To label the corporate limits and the Limit of Detailed Study, select "Edit
Landmark Table" from the "Edit" menu and enter the necessary information.
Click "OK" to save the changes. Note: This screen allows you to enter "Landmarks" on the FIRM.

Viewing and Editing the Profile (continued)
· Notice the gray lines that now appear on either side of the panel. These
lines indicate the landmark labels that you just entered.

Viewing and Editing the Profile (continued)
· Click on the "Panel" button and enter the necessary data under the
"General" tab. Note: This information will define the general characteristics and labels of the final flood profile.

Viewing and Editing the Profile (continued)
Next, enter the necessary data under the "Detail" tab.
Note: Only the "Start Station," "End Station," "Origin X," and "Origin Y" fields may be edited by the user.

Saving the Profile Table Database
· Click on the "Save" button to save the file. Save the file as "HECRAS.mdb".
The .mdb file that is saved here is the source file for the data used to generate the flood profile. It is important that you save this file
so that you have the flexibility to modify your data and generate updated profiles in the DXF editor.

Creating and Viewing the DXF File
· Click on the "DXF" button to create a DXF file. Name the file "HECRAS.dxf." Click "Save."
· Select "DXF Editor" from the "File" menu. This will launch the DXF Editor
and open the profile created for this HEC-RAS file.

Creating and Viewing the DXF File (continued)
· Notice that the Corporate Limits label is not positioned correctly.
· Click on the "Zoom Window" button on the top toolbar and zoom in on the
label.
· Click on the "Move" button on the left toolbar and move the label to the right approximately one block.
· Click on the "Save" button to save the revised flood profile.
Follow the same procedures as the HEC-2 Example for Creating and Viewing the DXF File.
Note: This file can be opened in AutoCAD® as a Drawing Interchange Format or Drawing Format File (DWG). Save the file as a
DWG file for use in AutoCAD®.

End of HEC-RAS Example
Congratulations, you have completed the HEC-RAS Example. Let's print out the final flood profile.
Print Dialog:
-Select "Print" from the "File" menu.
-Select "Click Pick" and then select the corners of the flood profile.
-Select the "Snap to Endpoint" icon located at the top of the right toolbar.
-Select "Printer" from the "Print Dialog" menu.
-In the "Print Setup" window, select the size of the profile (choose 11" x 17" and"Landscape" under the "Orientation" setting).
-Choose "0" for Origin's "X" and "Y", to center the profile plot.
-Select "Print" from the "Print Dialog" menu.

