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2.  ACCESSIBILITY CHECKER OPTIONS 

The Accessibility Checker Options gives you the opportunity to check for specific or all issues. To ensure your 
document meets FEMA 508 compliance, all items listed on the checker should be checked. 
 
When testing all PDFs, use the following steps first; 
 

1. Open your document in Acrobat 11 
2. Click on Tools 
3. Click on Accessibility 
4. Click on Full Check 
5. Click Start Checking 

The Accessibility Checker Options box will open. Compare your box to this and check all of the same boxes.  
 
Once your Accessibility Checker Options’ box has the same item checked off, click on “Start Checking.” 
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If you don’t see “Accessibility” under tools: 
 

1. Click on the small menu box in the upper right bar 
2. Scroll down and select Accessibility 

 

  

The Accessibility menu will stay populated until 
you change it.  
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3. TESTING DOCUMENTS FOR 508 COMPLIANCE 

To check your document for 508 issues or compliance open the document in a 508 true tester. FEMA has a list of 
the testers on the Intranet. For this document, we are going to use Adobe Acrobat 10. Acrobat 10 is the most widely 
used program for testing throughout FEMA. 
 
When testing all PDFs, use the following steps first; 
 

1. Open your document in Acrobat 10 
2. Click on Tools 
3. Click on Accessibility 
4. Click on Full Check 
5. Click Start Checking 

If you document is compliant, Acrobat will give you this message; 
 

 
 

If the document has errors, Acrobat will list all issues on the left side menu. 
     
 

 
 

Below are a few common errors and how to make these 508 compliant. 
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4. ADDING A READING LANGUAGE 

At the top left side of the Acrobat menu bar, click on File > Properties. 
 

 
 
Click on Pull Down list to choose a language. After you have selected the proper language, click on Ok. 
 

 
 
Once you click on OK, you will add the reading language to your entire document. This will allow the readers to 
read the document in the chosen language. 
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5. TAGGING DOCUMENTS FOR 508 COMPLIANCE 

The tag elements identify the objects in a PDF document and determine how a screen reader interprets a document. 

 

This module supplements “Making Accessible PDFs” and assumes you are working with Adobe Acrobat 
Professional 10. 
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A. CHECK FOR TAGS 

First, check for tags in the PDF document t by viewing “Tags.” There are two simple ways to get to the tag panel. 

Click on View > Show/Hide > Navigation Panes > Tags 

 

1. To dock the panel, click on the “Tags” tab and drag it to the navigation panel on the left; then release the 
mouse button.  

2. If the PDF is tagged, the tag panel will display a small plus sign (+) followed by an Adobe icon and the 
word “Tags.” 

3. If the document is not tagged, the tag panel will display an Adobe icon, followed by the words “No Tags 
available.”  

4. Match the Tag with the element on the page by turning on the Highlight Content option. Right click on a 
tag, select “Highlight Content” the element will be highlighted with a thin blue box when the tag is 
selected. 
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6. TAGGING AN IMAGE 

Among the most common changes made to image tags in PDFs are: 

• Adding alternative text to an image tag 
• Making an image a background element (see below) 
• Table structures 

A. ADDING ALTERNATIVE TEXT TO AN IMAGE 

Alternative text attributes are required for all images that add value to the document. The image’s text attribute will 
be read aloud by screen readers. 

The example below contains an image Acrobat reads as <InlineShape> with no alternative text. This could be 
called a number of items; figure, image, graphic, shape, etc. Alternative text must be specified for these items. 

To add alternative text: Right click on the tag. Click Properties. 
 

 

A Touch Up Properties dialog box will be displayed; enter descriptive text into the Alternate Text box. Adding a 
Title is optional; a Title will help the screen reader interpret the image. Click on “Close” to complete the change.  
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B. MAKING AN IMAGE A BACKGROUND ELEMENT 

Images that do not add value to the document and are purely decoration should be designated as a background 
object. These objects will not be announced by screen readers. 

From the main menu bar click on Tools > Accessibility > Touch Up Reading Order. The “Touch Up Reading 
Order” window will be displayed. Use the cursor to select your image then click on Background > Close. 
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7. CREATE ACCESSIBLE LINKS 

With thoughtfully provided links, users can quickly move from one part of a document to another, to 
related information in a different document, or to a website that is relevant to the content. 

For URLs to be accessible to screen readers, you must convert them to active links and make sure that 
they are correctly tagged in the PDF in the tag tree so that they are accessible to screen readers. 

Creating links with Acrobat Standard doesn’t generate any tags for the links. Do the following to make 
links active and add them to the tag tree: 

1. Select the text or object for which you want to create a link. 
2. Right-click the selection, and choose Create Link from the context menu. 
3. In the Create Link dialog box, select the appropriate options, and then follow the on-screen 

instructions to specify a URL, page view, or file as the link target. 

  

 
 
By default, the selected text for each link becomes the link text. After you add all the links, you can edit the tag tree 
to add alternate text to the links, further improving the accessibility of the PDF.  
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8. TAGGING TABLES 

Tables pose a special challenge for screen readers because they present textual or numerical data to be easily 
referenced visually. Content within table cells can be complex and might contain lists, paragraphs, form fields, or 
another table. 

For best results when tagging tables, use the application that you created the document with to add tags when you 
create the PDF. If a PDF isn’t tagged, you can add tags by using the Add Tags To Document command. Most tables 
are properly recognized using this command; however, the command may not recognize a table that lacks clear 
borders, headings, columns, and rows. Use the Touch Up Reading Order tool to determine if the table has been 
properly recognized and to correct recognition problems. To add specialized formatting to tables and table cells, use 
the Tags panel. 

You can use the Table Editor to automatically analyze a table into its components and apply the appropriate tags, 
but you may still need to check and correct some of these tags manually. By viewing table tags, you can determine 
whether columns, rows, and cells have been correctly identified. Tables that lack well-defined borders and rules are 
often tagged incorrectly or contain adjacent page elements. You can correct poorly tagged tables by selecting and 
redefining them; you can split combined cells by creating a tag for each cell.  

To correct complex tagging problems for tables, you often must use the Tags panel. 

1. Select the Touch Up Reading Order tool, and then click Show Tables And Figures. 
2. If the table isn’t clearly labeled in the document pane, drag to select the entire table, and then click Table in 

the dialog box. 
3. Click Show Table Cells to make sure that all cells in the table are defined as individual elements. 
4. If cells don’t appear as separate elements, do one of the following: 

o If one or more cells are merged, use the Touch Up Reading Order tool to select the area within a 
single cell, and then click Cell in the dialog box. Repeat for each merged cell.  

o If cells aren’t highlighted, the table might not use standard table formatting. Re-create the table in 
the authoring application. 

5. If the table contains cells that are intended to span across two or more columns, set ColSpan and RowSpan 
attributes for these rows in the tag structure. 

o Select the text or object for which you want to create a link. 
o Right-click the selection, and choose Create Link from the context menu. 
o In the Create Link dialog box, select the appropriate options, and then follow the on-screen 

instructions to specify a URL, page view, or file as the link target. 
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9. CORRECTING THE READING ORDER 

After the Accessibility Full Check is completed the results will populate in the left Accessibility Checker column. 
When you see “Logical Reading Order needs to be checked” follow these directions.  
 
Note: There are times when the checker doesn’t see an issue with the order. It is always a good habit to check the 
order to ensure it reads in order. It is also good to review the order in the Content  
 
When testing Reading Order, use the following steps first; 

1. Click on Tools > Accessibility, > Touch Up Reading Order > Show Order Panel 
2. Look at the numbers on your tags in your document. The items should read from the top and left to right. If 

the tags aren’t in the proper order continue to three. 
3. Place cursor over the number in the Order column, shift-click-drag item to the correct location (example 

below shows the title as number 10, this should be number one so you would hold down the shift key, click 
on number 10 and drag to the first position) 

4. Continue moving tags until the proper order is completed 
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10.    REMOVING AN ANNOTATION 

When a link is in the original document and not removed properly, it will leave an annotation that will cause the 
document to fail 508 compliance. The annotation will need to be removed. To find out where the annotation is 
located within the document follow the instructions for  
 
First follow the instructions under #2 Testing Document for 508 Compliance. To remove the unneeded annotation, 
use Acrobat and follow these steps; 
 

1. The errors will show up in the left hand menu under Accessibility Checker, Page Content, Tagged 
annotations Failed, Element 1. Be sure to see the page number and location of Element before you 
continue. 

 
 

 

2. Click on Tools > Content Editing > Add or Edit Link  
3. Click on the annotation error, a blue box will circle the annotation 
4. Click on Delete, the box will disappear.  

 
The box will disappear and the annotation will be removed. Save the document and upload to DIAMOND. 
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11.  LAYER ORDER 

 
If an item disappears, after you move it to the proper reading order, this means the layering of the objects need to be 
corrected. This can be done in  
 
1. Tools > Content Editing > Edit text and images.  
2. Right click on the item,  
3. Click on Arrange > Bring to Front. 
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12. ACCESIBILITY HELP DESK INFORMATION 

For questions, and access to further resources including training, please review the Office of Accessible Systems & 
Technology (OAST) intranet website or contact the DHS Accessibility Help Desk with any questions: 
 
• OAST: http://dhsconnect.dhs.gov/org/comp/mgmt/cio/oast 

• Accessibility Help Desk internal web site: Accessibility.DHS.gov 

• Accessibility Help Desk: Accessibility@DHS.gov 

• Creating Adobe Accessible files 

• HHS – Documents for 508 Compliance 

 
 

oast:%20http://dhsconnect.dhs.gov/org/comp/mgmt/cio/oast
http://accessibility.dhs.gov/
mailto:Accessibility@dhs.gov
http://www.adobe.com/enterprise/accessibility/pdfs/acro6_pg_ue.pdf
http://www.hhs.gov/web/508/training/testdocuments.html
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